re = /(?<=customer number|cust. nr).*\d+/m
str = 'bla bla customer number 1234 other text
bla bla again cust. nr. 1234 bla text '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end