$re = '/(?<=customer number|cust. nr).*\d+/m';
$str = 'bla bla customer number 1234 other text
bla bla again cust. nr. 1234 bla text ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);