package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\[([^][])]`)
var str = `[N][C@H]([C])[C](=O)[O]`
var substitution = "\1"
fmt.Println(re.ReplaceAllString(str, substitution))
}