use strict;
my $str = '[N][C@H]([C])[C](=O)[O]';
my $regex = qr/\[([^][])]/mp;
my $subst = '\\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";