const regex = new RegExp('\\[([^][])]', 'gm')
const str = `[N][C@H]([C])[C](=O)[O]`;
const subst = `\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);