using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!\d+\.\d{3})[a-zA-Z0-9. ]*$";
string input = @"GBP 23.44
23.44
23
23 GBP
234.44 GBP
234.44
23.334 GBP
234.443 GBP";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}