import re
regex = re.compile(r"^(?!\d+\.\d{3})[a-zA-Z0-9. ]*$", flags=re.MULTILINE)
test_str = ("GBP 23.44\n\n"
"23.44\n\n"
"23\n\n"
"23 GBP\n\n"
"234.44 GBP\n\n"
"234.44\n\n"
"23.334 GBP\n\n"
"234.443 GBP")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")