$re = '/^(?!\d+\.\d{3})[a-zA-Z0-9. ]*$/m';
$str = 'GBP 23.44
23.44
23
23 GBP
234.44 GBP
234.44
23.334 GBP
234.443 GBP';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);