using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?|.*?\|){4}(?'country'.*?)\|(?:.*?)\|(?'number'.*?)\|";
string input = @"89293661500:q2430173|251587385|М|20|Russia|Omsk|2|242|0|0";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}