re = /(?|.*?\|){4}(?'country'.*?)\|(?:.*?)\|(?'number'.*?)\|/m
str = '89293661500:q2430173|251587385|М|20|Russia|Omsk|2|242|0|0'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end