$re = '/(?|.*?\|){4}(?\'country\'.*?)\|(?:.*?)\|(?\'number\'.*?)\|/m';
$str = '89293661500:q2430173|251587385|М|20|Russia|Omsk|2|242|0|0';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);