using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=\.\s+)(#[a-zA-Z]+ *)+(?! *[^\s])";
string input = @"#abc #def This is a test paragraph. #ads I only want to remove the hashtags after the full stop at the end and keep the hashtag at the center. These hashtags should be removed. #ads #ime #abc
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}