using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:[^\|]+\|){2}\K(?P<q>[^\|]*)";
string input = @"2017-05-13|23:59:59|127.0.0.1|8080|ReGeX|http://www.example.com/index.htm|!""£$%^&*()_+|qwerty";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}