import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:[^\\|]+\\|){2}\\K(?P<q>[^\\|]*)";
final String string = "2017-05-13|23:59:59|127.0.0.1|8080|ReGeX|http://www.example.com/index.htm|!\"£$%^&*()_+|qwerty";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}