re = /^(?:[^\|]+\|){2}\K(?P<q>[^\|]*)/
str = '2017-05-13|23:59:59|127.0.0.1|8080|ReGeX|http://www.example.com/index.htm|!"£$%^&*()_+|qwerty'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end