using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:([ABC])(?!\1)([ABC])(?!\1|\2)[ABC])*$";
string input = @"BCAABCCBAABC
BCAAACCBAABA
ACB
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}