$re = '/^(?:([ABC])(?!\1)([ABC])(?!\1|\2)[ABC])*$/m';
$str = 'BCAABCCBAABC
BCAAACCBAABA
ACB
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);