re = /^(?:([ABC])(?!\1)([ABC])(?!\1|\2)[ABC])*$/m
str = 'BCAABCCBAABC
BCAAACCBAABA
ACB
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end