import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([a-zA-Z]+)(?<!default):([a-zA-Z]+)\\b(?!\\<)";
final String string = " foreach (mb:tMapBlock in MapBlockCollList){\n"
+ " foreach (obj:PhysicalObject in Class){\n\n"
+ "Local List:List<object>;\n"
+ " June 29, 2017, 28 12:43 AM �\n"
+ " MBListCount:+1;\n"
+ " default:m.enabled = !m.enabled;\n";
final String subst = "$2 $1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}