re = /([a-zA-Z]+)(?<!default):([a-zA-Z]+)\b(?!\<)/m
str = ' foreach (mb:tMapBlock in MapBlockCollList){
foreach (obj:PhysicalObject in Class){
Local List:List<object>;
June 29, 2017, 28 12:43 AM �
MBListCount:+1;
default:m.enabled = !m.enabled;
'
subst = '$2 $1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result