const regex = /([a-zA-Z]+)(?<!default):([a-zA-Z]+)\b(?!\<)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([a-zA-Z]+)(?<!default):([a-zA-Z]+)\\b(?!\\<)', 'gm')
const str = ` foreach (mb:tMapBlock in MapBlockCollList){
foreach (obj:PhysicalObject in Class){
Local List:List<object>;
June 29, 2017, 28 12:43 AM �
MBListCount:+1;
default:m.enabled = !m.enabled;
`;
const subst = `$2 $1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);