using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!^\h)(?<!^\h\h)(?<!^\h\h\h)(?<!\h\h\h\h)\b(\d{1,3})\.(\d{1,3})\.(\d{1,3})\.(\d{1,3})\b";
string input = @"
1.blah
1.1 blah blah
1.1.1 blah blah blah my ip address is 192.168.1.1
1.1.1.1 blah blah blah blah (DLP thinks this is an IP Address and block the document)
On the 1. January the profit rate was 3.5 %, and by article 3.1.4. in the agreement we sent that information to 127.0.0.1
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}