use strict;
my $str = '
1.blah
1.1 blah blah
1.1.1 blah blah blah my ip address is 192.168.1.1
1.1.1.1 blah blah blah blah (DLP thinks this is an IP Address and block the document)
On the 1. January the profit rate was 3.5 %, and by article 3.1.4. in the agreement we sent that information to 127.0.0.1
';
my $regex = qr/(?<!^\h)(?<!^\h\h)(?<!^\h\h\h)(?<!\h\h\h\h)\b(\d{1,3})\.(\d{1,3})\.(\d{1,3})\.(\d{1,3})\b/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}