using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<={)([\s\S]+?)(?=})";
string input = @"{0}{5}
{1}{dfdf}
{2}{пара, пара п.а пара&па®}
{3}{dfdf!}";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}