import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=\\{)([\\s\\S]+?)(?=\\})";
final String string = "{0}{5}\n"
+ "{1}{dfdf}\n"
+ "{2}{пара, пара п.а пара&па®}\n"
+ "{3}{dfdf!}";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}