const regex = new RegExp('(?:\\(|(?!^)\\G/)([^/)]+)(?=[^()]*\\))', 'gm')
const str = `Snarky Spark was at the stage with his team (Jerry Mander/Kodi Player/Bella Bella)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}