$re = '~(?:\(|(?!^)\G/)([^/)]+)(?=[^()]*\))~m';
$str = 'Snarky Spark was at the stage with his team (Jerry Mander/Kodi Player/Bella Bella)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);