re = /(?:\(|(?!^)\G\/)([^\/)]+)(?=[^()]*\))/m
str = 'Snarky Spark was at the stage with his team (Jerry Mander/Kodi Player/Bella Bella)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end