#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\ *(\d\w{8,19})\ *$"
Local $sString = "9291A5000000L9354087" & @CRLF & _
"9291A5000000L9354087 " & @CRLF & _
"" & @CRLF & _
" 9291A5000000L9354087" & @CRLF & _
"" & @CRLF & _
"72325302830" & @CRLF & _
"" & @CRLF & _
" 53138603044 " & @CRLF & _
"" & @CRLF & _
"0028A000000A99990819" & @CRLF & _
"" & @CRLF & _
"sd9AlL49020 " & @CRLF & _
"asdf9 94023409 9402" & @CRLF & _
"" & @CRLF & _
"A-1234" & @CRLF & _
" " & @CRLF & _
"This e-mail and " & @CRLF & _
"" & @CRLF & _
"Mobile: +43 123 45 67 890" & @CRLF & _
" +43 123 45 67 890" & @CRLF & _
" 43 123 45 67 890" & @CRLF & _
"43 123 45 67 890"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")