$re = '/^\ *(\d\w{8,19})\ *$/m';
$str = '9291A5000000L9354087
9291A5000000L9354087
9291A5000000L9354087
72325302830
53138603044
0028A000000A99990819
sd9AlL49020
asdf9 94023409 9402
A-1234
This e-mail and
Mobile: +43 123 45 67 890
+43 123 45 67 890
43 123 45 67 890
43 123 45 67 890';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);