import Foundation
let pattern = #"^\ *(\d\w{8,19})\ *$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
9291A5000000L9354087
9291A5000000L9354087
9291A5000000L9354087
72325302830
53138603044
0028A000000A99990819
sd9AlL49020
asdf9 94023409 9402
A-1234
This e-mail and
Mobile: +43 123 45 67 890
+43 123 45 67 890
43 123 45 67 890
43 123 45 67 890
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)