const regex = /(?=((\b(?:\w+\h+){1,3}keyword)(?:\h+\w+){1,3}))(?2)/ug;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?=((\\b(?:\\w+\\h+){1,3}keyword)(?:\\h+\\w+){1,3}))(?2)', 'ug')
const str = `word1 word2 word3 keyword word4 word5 word6 keyword word7 word8 word9 word10
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}