use strict;
my $str = 'word1 word2 word3 keyword word4 word5 word6 keyword word7 word8 word9 word10
';
my $regex = qr/(?=((\b(?:\w+\h+){1,3}keyword)(?:\h+\w+){1,3}))(?2)/up;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}