$re = '/(?=((\b(?:\w+\h+){1,3}keyword)(?:\h+\w+){1,3}))(?2)/u';
$str = 'word1 word2 word3 keyword word4 word5 word6 keyword word7 word8 word9 word10
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);