#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?<=<\/Profile>|^)((?!<\/Profile)[\s\S])*?(<limit>)[\s\S]*?(<\/Profile>)"
Local $sString = "<Profile sr="prof101" ve="2">" & @CRLF & _
" <flags>2</flags>" & @CRLF & _
" <Event sr="con0" ve="2">" & @CRLF & _
" </Event>" & @CRLF & _
" <App sr="con1" ve="2">" & @CRLF & _
" </App>" & @CRLF & _
"</Profile>" & @CRLF & _
"<Profile sr="prof102" ve="2">" & @CRLF & _
" <flags>2</flags>" & @CRLF & _
" <Event sr="con0" ve="2">" & @CRLF & _
" </Event>" & @CRLF & _
" <App sr="con1" ve="2">" & @CRLF & _
" </App>" & @CRLF & _
"</Profile>" & @CRLF & _
"<Profile sr="prof103" ve="2">" & @CRLF & _
" <flags>2</flags>" & @CRLF & _
" <limit>true</limit>" & @CRLF & _
" <Event sr="con0" ve="2">" & @CRLF & _
" </Event>" & @CRLF & _
" <App sr="con1" ve="2">" & @CRLF & _
" </App>" & @CRLF & _
"</Profile>" & @CRLF & _
"<Profile sr="prof104" ve="2">" & @CRLF & _
" <flags>2</flags>" & @CRLF & _
" <Event sr="con0" ve="2">" & @CRLF & _
" </Event>" & @CRLF & _
" <App sr="con1" ve="2">" & @CRLF & _
" </App>" & @CRLF & _
"</Profile>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")