import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=<\\/Profile>|^)((?!<\\/Profile)[\\s\\S])*?(<limit>)[\\s\\S]*?(<\\/Profile>)";
final String string = "<Profile sr=\"prof101\" ve=\"2\">\n"
+ " <flags>2</flags>\n"
+ " <Event sr=\"con0\" ve=\"2\">\n"
+ " </Event>\n"
+ " <App sr=\"con1\" ve=\"2\">\n"
+ " </App>\n"
+ "</Profile>\n"
+ "<Profile sr=\"prof102\" ve=\"2\">\n"
+ " <flags>2</flags>\n"
+ " <Event sr=\"con0\" ve=\"2\">\n"
+ " </Event>\n"
+ " <App sr=\"con1\" ve=\"2\">\n"
+ " </App>\n"
+ "</Profile>\n"
+ "<Profile sr=\"prof103\" ve=\"2\">\n"
+ " <flags>2</flags>\n"
+ " <limit>true</limit>\n"
+ " <Event sr=\"con0\" ve=\"2\">\n"
+ " </Event>\n"
+ " <App sr=\"con1\" ve=\"2\">\n"
+ " </App>\n"
+ "</Profile>\n"
+ "<Profile sr=\"prof104\" ve=\"2\">\n"
+ " <flags>2</flags>\n"
+ " <Event sr=\"con0\" ve=\"2\">\n"
+ " </Event>\n"
+ " <App sr=\"con1\" ve=\"2\">\n"
+ " </App>\n"
+ "</Profile>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}