# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<=<\/Profile>|^)((?!<\/Profile)[\s\S])*?(<limit>)[\s\S]*?(<\/Profile>)"
test_str = ("<Profile sr=\"prof101\" ve=\"2\">\n"
" <flags>2</flags>\n"
" <Event sr=\"con0\" ve=\"2\">\n"
" </Event>\n"
" <App sr=\"con1\" ve=\"2\">\n"
" </App>\n"
"</Profile>\n"
"<Profile sr=\"prof102\" ve=\"2\">\n"
" <flags>2</flags>\n"
" <Event sr=\"con0\" ve=\"2\">\n"
" </Event>\n"
" <App sr=\"con1\" ve=\"2\">\n"
" </App>\n"
"</Profile>\n"
"<Profile sr=\"prof103\" ve=\"2\">\n"
" <flags>2</flags>\n"
" <limit>true</limit>\n"
" <Event sr=\"con0\" ve=\"2\">\n"
" </Event>\n"
" <App sr=\"con1\" ve=\"2\">\n"
" </App>\n"
"</Profile>\n"
"<Profile sr=\"prof104\" ve=\"2\">\n"
" <flags>2</flags>\n"
" <Event sr=\"con0\" ve=\"2\">\n"
" </Event>\n"
" <App sr=\"con1\" ve=\"2\">\n"
" </App>\n"
"</Profile>")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.