package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[0-9]+|[a-zA-Z]+`)
var str = `TU111 1998 SUMMER
TU-232 SU 1999
TU232 1999 SUMMER`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}