// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"[0-9]+|[a-zA-Z]+").unwrap();
let string = "TU111 1998 SUMMER
TU-232 SU 1999
TU232 1999 SUMMER";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}