using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((https?:\/\/)?\b(?:(?!tenor|giphy|discord|clips|twitch|cdn|discordapp)\w)+\b\.[\w][^\s]+)";
string input = @"cdn.discordapp.com
tenor.com
giphy.com
discord.com
discordapp.net
clips.twitch.tv
xyz.com
http://xyzw.net
https://abcdef.org/xyz";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}