$re = '/((https?:\/\/)?\b(?:(?!tenor|giphy|discord|clips|twitch|cdn|discordapp)\w)+\b\.[\w][^\s]+)/m';
$str = 'cdn.discordapp.com
tenor.com
giphy.com
discord.com
discordapp.net
clips.twitch.tv
xyz.com
http://xyzw.net
https://abcdef.org/xyz';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);