import Foundation
let pattern = #"((https?:\/\/)?\b(?:(?!tenor|giphy|discord|clips|twitch|cdn|discordapp)\w)+\b\.[\w][^\s]+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
cdn.discordapp.com
tenor.com
giphy.com
discord.com
discordapp.net
clips.twitch.tv
xyz.com
http://xyzw.net
https://abcdef.org/xyz
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)