import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\d+\\.\\d+)(?=(?:.(?!\\d\\.\\d))*TEST)";
final String string = "asdasdasda\n"
+ "2.1 adasdasdasdasdwvwetwevtwtv\n"
+ "wetvwetv TEST wqrqwvrqw\n"
+ "qwvrqwvqwr\n"
+ "2.2 whergtvwe\n"
+ "wetvwetvwetveatw\n"
+ "evtwet\n"
+ "2.3 eyrnenytunrunert\n"
+ "vqevrerwv TEST aevtawtvwetv\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}