re = /^(\d+\.\d+)(?=(?:.(?!\d\.\d))*TEST)/m
str = 'asdasdasda
2.1 adasdasdasdasdwvwetwevtwtv
wetvwetv TEST wqrqwvrqw
qwvrqwvqwr
2.2 whergtvwe
wetvwetvwetveatw
evtwet
2.3 eyrnenytunrunert
vqevrerwv TEST aevtawtvwetv
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end