import re
regex = re.compile(r"^(\d+\.\d+)(?=(?:.(?!\d\.\d))*TEST)", flags=re.MULTILINE | re.DOTALL)
test_str = ("asdasdasda\n"
"2.1 adasdasdasdasdwvwetwevtwtv\n"
"wetvwetv TEST wqrqwvrqw\n"
"qwvrqwvqwr\n"
"2.2 whergtvwe\n"
"wetvwetvwetveatw\n"
"evtwet\n"
"2.3 eyrnenytunrunert\n"
"vqevrerwv TEST aevtawtvwetv\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")