use strict;
my $str = ' Account Source Source2 Source3 Source4 Source5
\'39\',\'39\'
\'41\',\'41\'
\'67\',\'67\'
\'286\',\'286\'
\'\',\'299\',\'2312210299\'
\'307\',\'307\'
\'341\',\'341\'
\'349\',\'349\'
\'351\',\'351\'
\'359\',\'359\'
\'362\',\'362\'
\'363\',\'363\'
\'378\',\'378\'
\'511\',\'511\',\'6218\',\'2197360511\'';
my $regex = qr/^('[0-9]*',?){3}$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}