re = /^('[0-9]*',?){3}$/m
str = ' Account Source Source2 Source3 Source4 Source5
\'39\',\'39\'
\'41\',\'41\'
\'67\',\'67\'
\'286\',\'286\'
\'\',\'299\',\'2312210299\'
\'307\',\'307\'
\'341\',\'341\'
\'349\',\'349\'
\'351\',\'351\'
\'359\',\'359\'
\'362\',\'362\'
\'363\',\'363\'
\'378\',\'378\'
\'511\',\'511\',\'6218\',\'2197360511\''
# Print the match result
str.scan(re) do |match|
puts match.to_s
end