#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?=([bc]*a){3})(?=([ca]*b){3})[ab]*(?:c[ab]*c[ab]*c[abc]*)?$"
Local $sString = "aaabbb" & @CRLF & _
"ababab" & @CRLF & _
"aaabbbccc" & @CRLF & _
"abcabcabc" & @CRLF & _
"ababcabcc" & @CRLF & _
"" & @CRLF & _
"ababcabccc" & @CRLF & _
"" & @CRLF & _
"aaabbbc" & @CRLF & _
"aabbb" & @CRLF & _
"abbccc" & @CRLF & _
"abcabca"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")