import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=([bc]*a){3})(?=([ca]*b){3})[ab]*(?:c[ab]*c[ab]*c[abc]*)?$";
final String string = "aaabbb\n"
+ "ababab\n"
+ "aaabbbccc\n"
+ "abcabcabc\n"
+ "ababcabcc\n\n"
+ "ababcabccc\n\n"
+ "aaabbbc\n"
+ "aabbb\n"
+ "abbccc\n"
+ "abcabca";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}