re = /^(?=([bc]*a){3})(?=([ca]*b){3})[ab]*(?:c[ab]*c[ab]*c[abc]*)?$/m
str = 'aaabbb
ababab
aaabbbccc
abcabcabc
ababcabcc
ababcabccc
aaabbbc
aabbb
abbccc
abcabca'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end